API for Upscope co-browsing is down
Incident Report for Upscope
Resolved
This incident has been resolved.
Posted about 1 year ago. Apr 27, 2018 - 22:17 UTC
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Apr 27, 2018 - 19:45 UTC
This incident affected: Dashboard and website.