There is an issue with our main database affecting screenshares
Incident Report for Upscope
Resolved
The issue has been resolved.
Posted about 1 year ago. Apr 18, 2018 - 18:02 UTC
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Apr 18, 2018 - 17:48 UTC